python: mysql-connector-pythonはpython3.8では使えないらしい

プログラミング
スポンサーリンク




python3.8がインストールされているパソコンで、mysql-connector-pythonをインストールをしようとしたところエラーが発生しました。

スポンサーリンク

エラー内容

UnsatisfiableError: The following specifications were found
 to be incompatible with the existing python installation in your environment:
 Specifications:
 mysql-connector-python -> python[version='>=2.7,<2.8.0a0|>=3.7,<3.8.0a0|>=3.6,<3.7.0a0|>=3.5,<3.6.0a0'] 
 Your python: python=3.8
 If python is on the left-most side of the chain, that's the version you've asked for.
 When python appears to the right, that indicates that the thing on the left is somehow
 not available for the python version you are constrained to. Note that conda will not
 change your python version to a different minor version unless you explicitly specify
 that.

原因

mysql-conector-pythonは、pythonのバージョンが2.7 ~ 3.7までの場合使用できるため、3.8では使用できないらしいです。

対処法

  • pythonのバージョンを下げる
  • 他のコネクターを使用する

私は、pythonのバージョンを下げることを選択しました。

むやみにバージョンをあげるべきではないと言いますが、こういうことが起こるんですね… 学びました。

anacondaのアンインストールからしないといけなかったので面倒くさかったです。

おすすめの書籍

SQLの第一人者であるジョー・セルコの名著『Joe Celkos SQL for Smarties, Fourth Edition: Advanced SQL Programming』の日本語版です。SQLプログラミングの基礎的な考え方から、テーブル操作、グループ化、集計関数、クエリの最適化など、ワンランク上を目指す上で欠かせない技術を学ぶ事ができます。

コメント

タイトルとURLをコピーしました